Rezer.net » Пользователи » Профиль » Модуль Интеграция DLE+IPB 1.1
Имеется админка Хак

Модуль Интеграция DLE+IPB 1.1

(бесплатные DLE модули)
Модуль Интеграция DLE+IPB 1.1
Версия: 1.1 Рейтинг:
 (голосов: 76)
Добавлен: 10 марта 2012 (02:43) Просмотров: 61094
Тип: Комментариев: 157
Совместимость: DLE: 8.x DLE: 9.x
Оф. страница: http://rezer.net/module/ipb/index.html
Все изменения в новой версии интеграции связаны в основном в поддержке новых версий форма IPB. Были добавлены настройки, для ручного указания имён полей регистрации и авторизации, также исправлены все заявленные ошибки.

Изменения в новой версии:
  1. В настройках модуля добавлены новые 4 пунтка:

    • Имя поля логина при регистрации/авторизации.
    • Имя поля пароля при регистрации/авторизации.

    Данные опции нужны для поддержки старых версий IPB 3.0.x и более новых.

  2. Добавлена настройка для новых версий форумов IPB, которая позволяет избежать ошибки выхода из форума, когда пишется: Ссылка "Выход" имеет не верный формат. Если у вас имеется такая ошибка, то достаточно просто включить эту опцию.
  3. В конвертере пользователей теперь показывается сообщение, когда модуль выключен. Ранее конвертер продолжал работу из-за чего случались некоторые проблемы.
  4. Устранены все известные проблемы.
Новая версия доступна как сайтов с кодировкой Windows-1251, так и для UTF-8.
Для работы модуля необходима версия PHP 5, установленное расширение Multibyte String.
Для обновления со старой версии достаточно произвести только одно изменение в файле.

При первой установки пожалуйста следуйте точно инструкции, изменения в файлах делайте внимательно. Также вам необходимо будет настроить относительные пути (корень сайта -> корень форума), как правильно их указать, читайте в спраке "http://help.rezer.net/level/24/nebolshoi-faq-76.html".
Ещё небольшое упоминание. Если вы не используете форум на субдомене, то в этом случае вам всё равно нужно указать домен Coockie на форуме, т.к. в DLE принудительно создаются куки, которые будут доступны и на субдоменах, именно из-за этого браузер применяет их.


Рекомендовать:

Комментарии  Rss комметарии

Автор  JustLive, 11 марта 2012 08:08
как обновиться?
Ответить
   
Автор  REZER, 11 марта 2012 17:59
В дистрибутиве есть инструкция. На эту версию обновление довольно лёгкое, изменение нужно сделать только в одном файле.
Ответить
Автор  caSper, 12 марта 2012 18:36
у меня чет после конвертации базы не заходит на форум под ником
Ответить
   
Автор  REZER, 13 марта 2012 00:43
Читайте внимательно справку по модулю. После конвертации пользователей с сайта на форум, необходимо первый раз авторизоваться на сайте (тоже самое, когда конвертация с форума на сайт).
Ответить
Автор  Виктор, 13 марта 2012 15:06
я как зашол на сайт и перехожу то там не авторизованый я там приходится входить сайт находится вместе с сайтом sait.ru/forum/index.php какие мне куку нада прописать&
Ответить
Автор  rambo, 14 марта 2012 13:48
Модуль встал без проблем, провел конвертацию, все синхронизировал. При входе в учетку на форуме, авторизация проходит и на сайте и на форуме, если авторизуюсь на сайте, на форуме авторизация не проходит. Общий выход работает везде. В настройках модуля и форума прописаны одинаковые куки, кеши почищены, форум и сайт находятся на одном домене. Стоит DLE 9.5 <-> IPB 3.0.5, версия модуля 1.0 в такой связке работала.
Ответить
   
Автор  REZER, 15 марта 2012 13:14
В первой версии по умолчанию были другие имена полей для форума, в частности там как раз были для IPB 3.0.5. Начиная с новой версии их можно настраивать, в справке (http://help.rezer.net/level/24/nebolshoi-faq-76.html) есть небольшая таблица, для вашей версии есть эти имена, их только нужно вписать в админцентр модуля.
Ответить
   
Автор  rambo, 15 марта 2012 13:38
Я сам немного тупанул, Все замечательно работает, эти поля я сразу прописал после обновления, нужно было все лишь куки и кэш у браузера почистить. Модуль отличный, спасибо.
Ответить
Автор  Ars_DK, 16 марта 2012 10:09
Всё отлично работает, но вот только не нравится мне ипб =
не планируете ли вы сделать аналогичную интеграцию для vBulletin 3.8.x?
Ответить
Автор  abgehackt, 18 марта 2012 09:39
Мне обновление, к сожалению не помогло. Выход с форума как глючил, так и глючит.
Новая опция "Выход с форума" тоже не помогает. При выходе с форума просто перекидывает на сайт, возвращаешься обратно на форум - пользователь залогинен.

Поигрался с браузерами. В IE.8 вроде хорошо, а FF.10 глючит. Кукисы конечно же чистил.

Автор, все равно большое спасибо за модуль! Вещь прекрасная. Возможно, мне повезет в версии 1.2 :)
Ответить
   
Автор  REZER, 18 марта 2012 18:38
В FF есть такая проблема, и при чём проблема не только с выходом из форума. Необходимо просто нажать Ctrl F5, чтобы он очистил кэш, в новой версии у него к сожалению есть небольшие запарки с этим. Бывает даже сам удалю комментарии, возвращаюсь они есть, после обновления страницы всё нормально.
Ответить
Автор  Storok, 4 апреля 2012 17:37
Установил модуль, DLE 9.5 и IPB 3.3. Хочу сообщить, что всё работает отлично! Большое спасибо за модуль!
Ответить
   
Автор  SPEED, 7 апреля 2012 01:02
Спасибо что отписал, а то завтра собираюсь тоже самое сделать...

P.S У тебя IPB 3.3.0 RU или EN ?
Ответить
Автор  chuchu, 10 апреля 2012 10:56
Скажите, пожалуйста, а будет ли модуль работать при авторизации с социальных групп?
Ответить
Автор  bitfam, 13 апреля 2012 23:53
пишется что модуль не включен как включить?
Ответить
Автор  SPEED, 14 апреля 2012 03:02
К сожалению у меня модуль не заработал... Увы.
Ответить
Автор  Tilacloto, 17 апреля 2012 11:00
Какой полезный топик
Ответить
Автор  wrowHaure, 5 мая 2012 03:55
Всем привет! Хотел похвалить Ваш сайт. Мне здесь очень понравилось.
Ответить
Автор  sadan, 26 мая 2012 06:59
Отлично ! Супер ! Очень долго ждал ! Спасибо ! Желаю успеха !
Хочу что бы личные сообщение тоже инт.
Тогда вообще суперски будет !

PS:
но увы почему то авторизация не работает


Ответить
Автор  feedalt, 3 июня 2012 15:01
На 9,6 нормально будет работать?
Ответить
Автор  Julius, 9 июня 2012 21:31
с IP.Board 3.3.1 и Dle 9.6 будет нормально работать? просто прочитал тут что поддерживается только до версии IP.Board 3.2.х
Ответить
   
Автор  vasya.vishnovsky, 11 июня 2012 15:36
У меня на 3,3,0 норм роботает. Есть баги но роботает
Ответить
Автор  vasya.vishnovsky, 11 июня 2012 15:36
Почему при бане пользователя на сайте дле, он автоматичиски удаляється с форума IPB
Ответить
Автор  _M_, 15 июня 2012 19:37
Будет ли вестись дальнейшие обновления для данного модуля?
Ответить
Автор  qwerty, 19 июня 2012 23:10
Могут ли возникнуть проблемы при установкеобновленииработе если папка admin на форуме переименована по соображениям безопасности? what
Ответить
Автор  Свикс, 23 июня 2012 20:14
тестировал на DLE 9.6 IPB 3.3.0 работает отлично!
но у меня почему то русские ники на форуме выводятся иероглифами (в Windows-1251 кодировке), с английскими никами все окей, как исправить?
Ответить
   
Автор  MontIQ, 23 мая 2013 21:36
UTF-8 установить !
Ответить
Автор  almaz, 25 июня 2012 16:57
не смог установить!!! запарол сайт и форум кто может помочь напишите в аську 127340986
в долгу не останусь
Ответить
Автор  djgelius, 28 июня 2012 12:52
как удалить этот модуль форум больше не нужен?
Ответить
   
Автор  _M_, 5 июля 2012 07:37
делайте все по инструкции только в обратном порядке
Ответить
Автор  _M_, 5 июля 2012 07:37
ipb 3.3.3 & dle 9.6 работает нормально...
Но кажись дальнейшей поддержки модуля не будет =(
Ответить
Автор  fraerokPB, 11 июля 2012 08:06
Вот я ни как не пойму помогите!!!!

1) Путь к корню форума относительно корня сайта!
полный путь:/home/www/ЛОГИН_МОЙ/data/www/САЙТ.ru/forum
Что вписать в файл:ipb.class.php?
2) Путь к корню сайта относительно корня форума!
прлный путь:/home/www/ЛОГИН_МОЙ/data/www/САЙТ.ru
Что вписать в файл:index.php? (В папке форума)
Ответить
Автор  user, 21 июля 2012 19:34
есть тут поддержка установки форума в отдельную папку не на поддомен? если нет, как это реализовать?
Ответить
Автор  metelevmv, 26 июля 2012 12:30
Здравствуйте, помогите мне пожалуйста. Я поставил ваш модуль интеграции версии 1.1, все работает ошибок на сайте нету, но форум не хочет работать, просто не грузится и все. Подскажите где возможна ошибка?
Ответить
Автор  dark-king, 1 сентября 2012 11:40
После установки модуля интеграцыи DLE ibp возникла проблма с открытием форума ( в админ панеле DLe отсуцтвует модуль интеграци ....
прошу ответить

(когда пробую установить заново Пишет что модуль установлен ( но его нету =) ))
Ответить
Автор  Mpow3r, 17 сентября 2012 02:34
все прописал установил, сайт и форум работает, но когда на форуме пытаюсь выйти перекидает на сайт и выходит на сайте, что делать в админке все перепробовал не помогает
Ответить
Автор  warp lighthouse, 15 ноября 2012 17:32
Попытался авторизоваться
Получил это:

Ответить
Автор  fRost1kw0w, 23 декабря 2012 17:51
Здравствуйте уважаемые пользователи :)
Установил все.
Версия Dle 9.7, Версия Ipb 3.2.x
Модуль работает нормально. Но при заходе на форуме выдает ошибку:

Ответить
Автор  neatek, 26 декабря 2012 21:14
а как зарегистрировать пользователей с DLE которые не зарегистрированы на форуме?
Ответить
Автор  dimiva22, 30 декабря 2012 21:04
Поможете установить за 20 грн?
Е-МЕЙЛ: dimidron4ik@ukr.net
SKYPE: dimidro_on4ik
Ответить
Автор  Sultane), 14 января 2013 20:51
Привет всем так интегрировал Dle 9.7 IPB 3.4.1 ! Все нормально проблем нет)

Если надо интегрирую форум и Сайт)

Майл: Tanirkul.sultan@mail.ru(Рекомендую писать сюда)
Hotmail: Tanirkul.sultan@hotmail.com
Ответить
   
Автор  zadrot123, 20 января 2013 16:15
бесплатно?
Ответить
   
Автор  Sultane), 20 января 2013 18:48
100Рублей! Нормально?
Ответить
Автор  zadrot123, 20 января 2013 15:58
помогите решить проблемму

Warning: require_once(../forum/engine/inc/ipb/ipb.class.php): failed to open stream: No such file or directory in /home/nick/public_html/forum/index.php on line 22 Fatal error: require_once(): Failed opening required '../forum/engine/inc/ipb/ipb.class.php' (include_path='.:/usr/lib/php') in /home/nick/public_html/forum/index.php on line 22
Ответить
   
Автор  sultane, 20 января 2013 18:51
Не правильно заданы пути
Ответить
   
Автор  zadrot123, 23 января 2013 16:43
а куда нужно путь указать напишите пожалуйста
Ответить
   
Автор  sultane, 25 января 2013 18:31
Простите но я не экстрасенс
Ответить
Автор  Sultane), 20 января 2013 18:47
Привет всем так интегрировал Dle 9.7 IPB 3.4.1 ! Все нормально проблем нет)

Если надо интегрирую форум и Сайт)

Майл: Tanirkul.sultan@mail.ru(Рекомендую писать сюда)
Hotmail: Tanirkul.sultan@hotmail.com

За 100рублей! Максимальный фунционал
Ответить
Автор  zadrot123, 23 января 2013 16:43
будет роботать на ipb 3.3.4 ?
Ответить
Автор  darkk, 24 января 2013 10:08
Sultane, напиши плс гайд что ты делал. winked
Ответить
Автор  Green-steel, 3 февраля 2013 17:30
Здравствуйте поставил ваш модуль к себе на сайт всё робит на 100% движок Dle 9.7 IPB 3.4.2 Но вот одна проблема с кодировками при выводе последних статей на сайте английский конает норм а вот вместо русского вот что
??????j?‰?? ???? ?„???€?????? IPB
Подскажите как исправить плиз
Ответить
   
Автор  Green-steel, 10 февраля 2013 16:15
Ну кто нибудь помогите ?
Ответить
   
Автор  MontIQ, 23 мая 2013 21:37
Кодировку сменить на UTF-8!
Ответить
Автор  Green-steel, 19 февраля 2013 12:44
Сори всё в норме просто не тот архив скачал winked
Ответить
Автор  vakusapp, 11 марта 2013 11:33
Здравствуйте
Возникла проблема,не могу писать посты на форуме, часто выдает
ошибку FlashScript 458 Error
Что это может быть ?
Ответить
Автор  rogTagRetoure, 24 марта 2013 00:44
Продам полностью рабочий Xrumer, любые проверки.
В сборку входит рабочий хрумер, scrapebox.
Достоинства Хрумера 7.0.12:
1) Русская версия
2) НЕТ вылетов может сутками работать без перебоев
3) К хрумеру привязан CapthaSniper что намного увеличивает пробив
и еще много чего, вообщем все функционирует на отлично.
ScrapeBox использую только для пинга, а так она тоже полностью рабочая и можете ее использовать как хотите на сколько у Вас фантазии хватит.
Все это добро запускается через виртуальную машину.
Эту сборку мне разрешил продвать ее создатель. Сборку бесплатно и наперед никому давать не буду, только после оплаты.
Цена: 1750 рублей. Оплата только на киви кошелек.
Мой скайп: alexromanov324
Ответить
Автор  RaNDoM, 3 апреля 2013 11:49
Добрый день, помогите пожалуйста решить проблему:
Выдает такую ошибку на последенм этапе установки
Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /home/username/site.ru/engine/inc/ipb/ipb.class.php on line 14


Dle 9.7 IPB 3.3.x
Ответить
Автор  megapupsik, 9 апреля 2013 14:02
Недавно наткнулся на информацию о новой секте! Будти осторожны, говорят людей туда затягивают и обратно никто не возвращается!
https://vk.com/potomu_4to_nam_pohui
Ответить
Автор  Virus25, 6 мая 2013 10:38
Вопрос как сделать интеграцию если ipb и DLE в разных базах?
Ответить
Автор  Casillas, 20 мая 2013 22:10
Помогите исправить. Когда включаешь опцию Выход с форума, то не работает выход в мозиле и хроме, если отключаешь опцию то не работает выход в опере.
Ответить
Автор  okyjiuct, 20 июня 2013 19:39
Возник вопрос, напрямую не касающийся данного модуля, но может кто сталкивался. Поставил на сайт uLogin однако при копировании кода из register.php в ulogin.php

include_once( ENGINE_DIR."/inc/ipb/ipb.class.php" );
$IntegrationIPB->Register( "ipb", array(
"name" => $name,
"password" => $user_arr[2],
"email" => $email,
"icq" => $icq,
"fullname" => $fullname,
) );

регистрация на форуме не проходит, а появляется ошибка Fatal error: Call to a member function SaveConfig() on a non-object in /var/www/user/data/www/site.ru/engine/inc/ipb/cache.php on line 46

Разумеется, переменные взяты актуальные и существующие. Подскажите, в чем может быть проблема?
Ответить
Автор  елена, 25 июля 2013 21:52
с форума не выходит. нажимаю ВЫХОД, перебрасывает на dle. как решить? sad
Ответить
Автор  westbrook, 17 октября 2013 02:53
dle 10.0 и ipb 3.4.5 полёт нормальный
Ответить
Автор  fira_fira, 31 октября 2013 20:50
Не работает вывод списка последних сообщений на dle сайте.
Ответить
Автор  nebula, 10 апреля 2014 13:41
Доброго времени суток!
у меня вроде бы все работает,но есть 2 момента.

1.Авторизуюсь на форуме - на сайте не авторизует.
2.Регистрирую юзера,выдаю ему в админке DLE права админа ( меня группу ) - исчезает юзаер из IPB.

как пофиксить?
Ответить
Автор  Templates, 23 апреля 2014 06:59
ребята подскажыте как правильно указать пути в index.php и ipb.class.php если форум стоит на forum.site.ru а сайт на site.ru панель ISPmanager .
Ответить
Автор  GeorgeCain, 11 мая 2014 16:53


как полностью удалить модуль

из админ панели удалил а файлы остались.
Мне это нужно чтобы потом заново его поставить
Ответить
Автор  SkyFox, 27 мая 2014 00:56
DLE 10.2 IPB 3.4.6 --- то ли я криворукий, что вряд ли, то ли лопата не копает. Нифига не работает. Мало того CSS верстка летит к чертям. Короче не скрестить бульга с носорогом.
Ответить
Автор  Respect™, 30 июня 2014 04:01
Такой вопрос почему аккаунты с DLE не переносятся в IPB?
Ответить
Автор  Thomasrof, 4 октября 2014 06:41
Подскажите где можно найти порно рассказы спящая
Ответить
Автор  skerator, 15 октября 2014 21:33
Модуль конечно работает но не идеально. Нашел ошибку в файле memberSync который дает возможность при авторизации на форуме авторизоватся в dle. Из за этого:
При авторизации на форуме появляется белая страница. Но при этом авторизация проходит на dle, но не проходит на форуме! При авторизации пустая страничка появляется (просто белая) forum.site.ru/index.php?app=core&module=global§ion=login&do=process
Ответить
Автор  MrLOLs, 18 декабря 2014 07:40
Обновите для DLE 10.3 IPB 3.4.6
Ответить
Автор  Zohan, 19 февраля 2015 00:01
На dle 10.4 работает?
Ответить

 

Внимание! Обо всех ошибках необходимо писать на форуме (все комментарии с ошибками на сайте будут теперь удаляться).
Уведомление! Обращаем ваше внимание на то, что вы можете оставить отзыв о модуле.


Отправить
# Название Версия Дата выхода
1 Интеграция DLE+IPB 1.1 1.1 10 марта 2012 (02:43)
2 Интеграция DLE+IPB 1.0 1.0 19 декабря 2011 (00:44)

* Как только выходит новая версий дополнения, то все старые автоматически пропадают с сайта и заменяются на новую.
* Если вы хотите посмотреть изменения старых версий, то можете переходить в них отсюда.
Возможности дополнения 1.1
Поддержка поддомена Да
Поддержка 2х БД Да
Общая регистрация Да
Общая авторизация Да
Общая разавторизация Да
Общее восстановление пароля Да
Общее изменение пароля Да
Общая смена email Да
Блок "Последние сообщения" Да
Конвертер из DLE в IPB Да
Конаертер из IPB в DLE Да
Общее удаление в админцентре DLE Да
Общая смена логина в админцентре DLE Да
Общее редактирование в админцентре DLE Да
Поддержка IPB 3.0.x Да
Поддержка IPB 3.1.x Да
Поддержка IPB 3.2.x Да
Поддержка UTF-8 Да
Если, какая-то возможность не отмечена в данном списке, значит она поддерживается в новых версиях данного дополнения. Вы также можете опционально сравнить все возможности имеющихся версий данного дополнения на этой странице.
Скачивание файлов

Для того, чтобы скачать файл, необходимо быть зарегестрированным и авторизированным пользователем сайта. Перейдите по ссылке "Скачать" и выберите необходимый файл для загрузки (версию DLE, модуля и т.д). Если дополнение платное, то вам придётся сначала купить его.

Форум поддержки

Все вопросы, ошибки и пожелания для новых версий вы можете оставлять на форуме. Для каждого дополнения имеется отдельная тема. Чтобы не засорять форум и не искать эту тему, вы можете перейти в неё по ссылке, указанной ниже.

Документация по модулю

Прочтите полную документацию по данному модулю и узнайте как работать со всеми функциями модуля.


Скачать Форум Документация

Авторизация Регистрация
Интеграция DLE + IPB
  Реклама
Сегодня без рекламы
  Важный опрос
Ваша версия DLE

(Ваш вариант)

   Результаты
  Последние новости
  Счётчики
Rambler's Top100
Мы принимаем
Проверить аттестат www.megastock.ru